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Microsoft Excel is a spreadsheet software program for use in organizing data, performing data 
calculations, and graphing datasets. 
 
Basics  

Worksheet Layout 
Entering Text and Numbers 
Formatting Text, Numbers, and Cells 

 
Using Data Shortcuts  

Autofill 
AutoSum 
Formulas  
Fill Right, Fill Down 
Sorting  

 
Presenting the Information  

Page Setup Options 
Printing Options 
Creating Charts 
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BASICS 
 
Worksheet Layout 

Rows and Columns:  
Each worksheet is composed of rows 
(numbered) and columns (lettered).  

 
Cells:  

The intersection of each row and 
column creates a cell. The cell is 
identified by its location on the 
worksheet (i.e. B3).  
An active cell is outlined in black and 
the location appears in the Name box 
(D2 is active in Fig. 1).  
 

Worksheet/Sheets: 
Each page of cells is called a worksheet 
or sheet. Multiple worksheets are 
available in each Excel file.  
Click on the Sheet tab to access a new worksheet. The Sheet tabs can be renamed by 
double-clicking on the current tab name, then typing the desired name. 
 

Formula Bar: 
The formula bar displays the contents of an individual cell. The contents may be text, 
numbers and/or formulas, depending on the cell.  

 
Entering Text and Numbers 

Moving the cursor: 
You can move the cursor using several options on the keyboard: 

  Tab key- moves one cell to the right (along the row) 

  Shift-Tab keys- moves one cell to the left (along the row) 

  Enter key- moves one cell down (along the column) 

  Shift-Enter keys- moves one cell up (along the column) 

  Cursor keys (arrow keys)- moves one cell in direction of arrow on key  

Any cell can also be activated by clicking on it using the mouse. 

Entering content:  
Once the cursor is in the appropriate cell, enter the content using the keyboard. Cells will 
accept text or numbers, as well as equations (see formula section for details). 
There are a few default settings that become evident once there is content in a cell: 

Numbers are right-justified. 

Text is left-justified. 

Whole numbers will not display zeros after the decimal point (unless the cell has 
been specially formatted). 

 
 

Active cell 

Formula Bar 

Active cell 

Fig. 1 Sheet tab 
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Cutting and Pasting Cells: 
• To move a filled cell, click on the cell to activate it, 

and press Ctrl-X on the keyboard (or go to the Edit 
menu and select Cut). The activated cell will be 
encircled by a flashing dotted line (Fig. 2).  

• Move the cursor to the desired blank cell and press 
Ctrl-V (or go to the Edit menu and select Paste).  

• To move a group of filled cells, hold down the left 
mouse button and drag the cursor over the group of 
cells, selecting all of them. Then complete the cut 
and paste commands. 

 
 Inserting Rows and Columns: 

To insert a row: 
Activate a cell. Under the Insert menu, select Row. The row will be added above the 
row containing the activated cell 
 
To insert a column: 
Activate a cell. Under the Insert menu, select Column. The column will be added to the 
left of the column containing the activated cell. 

 
Editing Cell Content: 

The contents of any cell can be edited at any time. To see the cell’s contents, click on 
the cell and look in the formula bar. Click with the cursor in the formula bar to add or 
remove content at that location. 
 

Formatting Text, Numbers, and Cells 
 Selecting Rows or Columns: 

To select an entire row, click on the number of the row in the gray column on the left. 
To select an entire column, click on the letter of the column in the gray row at the top. 

 
 Formatting Text: 

Font/Point Size/Bold/Underline- Once the desired cell(s) have been selected, click the 
appropriate formatting button in the toolbar at the top of the screen (Fig. 3) to alter the 
appearance of the text in that cell(s). 

 
 
 
 
 
 

Subscripts/superscripts- To add subscripts or superscripts to a cell, highlight the 
letter/number in the formula bar. Under the Format menu, select Cells…. Check the 
box for superscript or subscript as desired. 

Fig. 2 

Fig. 3 

Font Point Size Bold Underline 
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Alignment-  
• Left/Center/Right: To change the default horizontal alignment of a cell’s contents, 

select the cell(s) or row(s)/column(s), and click the appropriate alignment button 
on the tool bar. (Fig. 4) 

 
 
 
 

• Top/Center/Bottom: To change the default vertical alignment of a cell’s contents, 
select the cell(s). Under the Format menu, select Cells…. Click on the Alignment 
tab (Fig. 5), and choose the desired alignment from the Vertical drop down menu. 

 
 
Wrapping text- In some cases, the content in a cell will exceed the amount of space 
available. If there is extra text, only the beginning of the text will be visible. If a 
number is too long to fit, the cell will display #####, rather than the number. To fix this 
problem you could increase the 
width of the column (see 
Formatting Cells), or you can 
format the cell to allow the text to 
wrap onto a second line within the 
cell. 
• Select the cell(s) that need to 

have text on multiple lines. 
(Entire columns or rows can 
also be selected.)  

• Under the Format menu, 
select Cells…. 

• Click on the Alignment tab 
(Fig. 5). 

• Check the box for Wrap Text. 
 
Merging and Centering cells- 
Sometimes text needs to be centered 
over multiple columns. Rather than 
trying to guess which column is the 
central one and typing the text in that  
column’s cell, the entire set of cells in that row can be combined. 
 

• Select the cells.    
• Click the Merge and Center button on the toolbar. (Fig.6)    
• The same process can be done via the Alignment window (Fig. 5 above) by 

checking the Merge cells box and horizontally centering the text. 

Left, Center, Right alignment 

Fig. 4 

Fig. 5 

Fig. 6 
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Formatting Numbers:  
Number of decimal places- Select the 
cell(s). Under the Format menu, select 
Cells… and click on the Number tab. 
Click on Number to see the decimal 
place options (Fig. 7). 

 
Decimal places alignment- Since Excel 
does not retain zeros at the end of a 
number (i.e. 2.0), it can be difficult to 
line up a column of numbers with 
inconsistent numbers of decimal places. 
To increase or decrease the number of 
decimal places for a column (and 
thereby unify the number of decimal 
places), select the column and click on 
the appropriate button in the toolbar. (Fig. 8) 

 

 
 
 

 
Special notation (currency, dates, etc.)- Additional formatting options for currency ($), 
times, dates, zip codes, social security numbers, and phone numbers are found under the 
Format menu, Cells…, and Number. 

 
 Formatting Cells: 

Column width/Row height- To expand or contract the width of a column, select the 
column. Placing the cursor in the gray 
row at the top of the column, drag the 
right or left edge to make it wider or 
narrower. 
 
Double-clicking on this edge will 
automatically adjust the width to fit the 
widest content in that column. 
Row height can be altered in the same 
manner, dragging or double-clicking on 
the top or bottom edge in the gray 
column on the left side of the worksheet. 
 
Borders and Patterns- Borders can be 
placed around a cell or group of cells 
using the border option. Under the 
Format menu, select Cells…. Select Border. The number of sides and the  
type of line can be selected from this window. (Fig. 9) 
Patterns and colors are also available in the adjacent tab. These options should be used 
cautiously as it can be difficult to read data when the cell also contains a color or pattern. 
 

Fig. 7 

Increase decimals, Decrease decimals 

Fig. 8 

Fig. 9 
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 Delete vs. Clear: 

Two options are available to remove the contents of a cell: 
 Delete will remove the numbers or text, but retain any formatting. 
 Clear will remove both the content and the formatting. 

 
Removing Rows and Columns: 

To remove an entire row or column, click the letter (for column) or number (for row). 
Under the Edit menu, select Delete. 

 
 
USING DATA SHORTCUTS 
Autofill 
 A quick shortcut to add a series of text is to use the Autofill function.  

• Enter the first term in the series (i.e. January, Monday, First Quarter, etc.) 
• Using the mouse, drag the small black square in the lower right corner of the cell 

across the rows or down the column to fill in the remaining portion of the series. 
 
AutoSum 

Summing a column or row of numbers can be done easily by clicking the AutoSum 
button in the toolbar. (Fig. 10)  

• Place the cursor in the cell that will contain the total. 
• Click the AutoSum button.  
• The cells to be added will be enclosed in a flashing dotted line. Make sure all of the 

appropriate cells are included. If there are blank cells in the midst of the row or 
column of numbers, the outline will have to be added manually by dragging the 
cursor across the desired cells. 

• The range of cells can also be double-checked by viewing the formula generated in 
the original cell. For example, to add the contents of cells B3 through B10, the 
generated formula should read  

  =SUM(B3:B10) 
• Press Enter to view the total. 

 
Formulas 

Excel can also perform other types of mathematical calculations including multiplication, 
division, and subtraction.  

• To enter a formula, click in the cell that will hold the results of the equation. 
• Press the equal sign to start the formula, then enter the cell names and notations to 

complete the formula. For example, to subtract the value of B5 from B3, the 
equation would read 

  =B3-B5 
Note: Use the asterisk (*) for the multiplication symbol, and the forward slash(/) for 
the division symbol. 

 
Fill (Right, Down) 

Once a formula has been created, it can be automatically added to adjacent cells in a row or 
column (adjusted for the row number or column letter).  

• Put the cursor in the cell containing the formula. 
• Holding the mouse button down, highlight the adjacent cells that will contain the 

modified formula. 

Fig. 10 
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• Under the Edit menu, select Fill. From the submenu, select the appropriate direction 
(i.e. right, down, etc.). 

• The formulas will be added to the cells. The formula for each of the adjacent cells 
can be double-checked by clicking in the cell and viewing the contents in the 
Formula bar. If there is no data on which to perform the calculation, the cell will 
contain a zero.  

 
Sorting 

Once data has been entered, it is possible to 
sort the information into a different sequence, 
retaining the link between the label and the 
numerical information. 

• Highlight the rows or columns to be 
sorted, clicking on the gray row 
number or column letter to select the 
entire row/column. 

• Under the Data menu, select Sort…. 
• Select how the sort should occur 

(ascending or descending) and which 
column determines the sorting method. 
(Fig.11) 

• Check the appropriate button to 
indicate whether or not a header row 
has been included in the highlighted 
rows of data. 

• Click OK to perform the sort. 
• Multiple-level sorts can be performed using the addition sorting levels in the 

window (i.e. Sort sales by month, then by salesperson). 
 
 

PRESENTING THE INFORMATION 
 
Page Setup Options 

Orientation 
Excel spreadsheets are often wider than 
they are long, so many will benefit from 
changing the orientation of the page from 
portrait (vertical) to landscape 
(horizontal). 

• Under the File menu, select Page 
Setup. 

• Click the button for the 
Landscape orientation. (Fig. 12) 

 
Fit to One Page 

Spreadsheets can also be automatically 
scaled to fit onto one (or more pages). 
Click on the Fit to button and enter the page specifications. (Fig. 12) 
Note: The resulting text size may be quite small. 

Fig. 11 

Fig. 12 
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Margins 

Margins can be altered to 
provide additional space for 
data. (Fig. 13) No margin 
should be smaller than .5 
inches in order to avoid cutting 
off part of the data when 
printing. 

 
Centering on Page 

To center small blocks of data 
on the page (without altering 
the margins), click the 
appropriate box in Page Setup-
Margins (horizontally, 
vertically).  
(Fig. 13) 
 

 
Header/Footer 

Headers and Footers provide a 
convenient location for small 
pieces of information. Common 
elements of these two text areas 
are page numbers, dates (creation 
or printing date), times, author 
name, version number, and/or 
project name. 
 
Standard options and formatting 
are available under the Header 
and Footer drop down menus, 
(Fig. 14) however custom options 
are also available.  
(Fig. 15) 
 
To create a custom 
header or footer, place 
the cursor in the 
desired section and 
type in the appropriate 
text (project name, 
author name, etc.) 
Some of the standard 
options (date, page 
number, etc.) can be 
added by clicking on the appropriate button. Fig. 15 

Fig. 13 

Fig. 14 
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Sheet 
If a spreadsheet spans 
multiple pages, it can be 
helpful to include the 
row/column containing the 
headings on each page. To 
automatically add this option, 
in the Print titles area, click 
on the appropriate colored 
square (rows or columns), 
then click the gray row 
number or column letter to 
add the absolute value to the 
setup options. (Fig. 16) 

 
 
 
Printing Options 
 Print Area 

To print only a portion of a spreadsheet, highlight the desired area. Then under the File 
menu, select Print Area-Set print area. When the print command is given, only the 
highlighted area will print. Choose Clear Print Area to remove a previous setting. 
 

 Gridlines 
The default Excel setting is printing without visible gridlines between the cells. However, 
sometimes it is helpful to be able to see the cell divisions.  
To print the spreadsheet with visible gridlines, select File-Page Setup-Sheet and click the 
box for Gridlines. (Fig. 16) 
 

Creating Charts 
Once the data has been entered into the spreadsheet, a graph or chart can be created. The 
graph can contain portions of the spreadsheet or the entire data set.  

 
• Highlight the data to be graphed.  

    
• Click on the Chart Wizard button (Fig. 17) in  

the tool bar to go through the four step process. 
 

• In step 1, select the type of graph desired on 
the left, then the appearance of that type of 
graph on the right side. (Fig. 18) 

 
 
 
 
 
 
 
 
 

Fig. 16 

Fig. 17 

Fig. 18 
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• In step 2, confirm the data range.  

(Fig. 19) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

• In step 3, make any 
desired adjustments 
to the chart title and 
location of the 
legend. (Fig. 20) 
Options for adding 
labels to the 
individual data 
pieces (raw number, 
percentage, etc.) are 
also available. 

 
 
 
 
 

• In step 4, decide whether 
the chart should be part 
of the current worksheet 
or be on a new 
worksheet. (Fig. 21) 

 
• Click Finish to add the 

completed chart to your 
worksheet. 

Fig. 19 

Fig. 20 

Fig. 21 


